Aide - Recherche - Membres - Calendrier
Version complète : apres installation de mandrake
Forum GenerationMP3 > Matériel, Informatique et Electronique > MP3 & Informatique > Musique digitale et Linux
kenlesurvivant
Salut tout le monde.Alors voila je vous explique j'ai telecharger mandrake 10.1 car je voulais essayer linux donnc je l'ai installé sur un espace libre de mon disque dur,l'installation se passe nikel,au redemarrage je choisi de redemarrer linux ou windows ou 2autres choix.Lorsque je choisi linux,l'on voit la barre de chargement de mandrake puis arrivé au bout j'ai un ecran noir genre dos qui me demande mon login,alors que je n'en ai pas.
Je l'ai deja réinstallé 4 fois,ça n'a rien changé alors que chez potes tout est passé nikel.Aidez moi!!!!!!
kenlesurvivant
J'ai oublié une petite infos,lorsque le systeme linux se charge.avant de me faire l'ecran noir il fait toujours une verification du systeme de fichier.tout est ok sauf un fichier ou il met echec c'est "activation de l'interface eth0"
Quelqu'un saura t'il m'aider???
manudeparis
tu as essayé de taper quelque chose pour voir ?
deagle67
t'as oublié de te créer un login pendant l'installation..
à un moment, je sais plus quand mais après la demande du mot de passe administrateur, tu auras la possibilité de te créer des comptes, il faut cliquer sur Ajouter je crois

sinon ya moyen de créer un compte en passant par le login root, mais j'ai jamais fait
kenlesurvivant
bah en fait je me cree mon compte et quand je redemarre et qu'il me demande le login, je le tape,j'appuie sur entre ,il me demande le password et la je ne peux rien ecrire.j'attend un peu et la il m'ecris login incorrect.en plus je suis sur que le login et le bon,c'est la 4eme fois que je l'installe!!!!
Basaltinou
Tu peux écrire, mais ça ne s'affiche pas...
Et pour l'interface eth0, c'est juste que tu n'as rien branché sur ton port ethernet, donc il n'arrive pas à activer la carte réseau...
kenlesurvivant
c normal donc que dans password rien se s'ecrive?
avez vous du vous aussi passé par cette etape car un ami a moi la installé sur son ordinateur il ne se souviens pas avoir du passé pas cette etape
Basaltinou
C'est normal...
Mais là je crois que t'as tout simplement installé d'interface graphique car normalement le login se fait en graphique et pas en console...
Nova0_0
Alors, lors de l'install il t'as demandé un mot de passe root...

Lorsque tu démarres linux, il te demande ton login (root si tu n'en as pas créé, un autre sinon) puis un mot de passe. Celui-ci est caché, même quand tu le tappes pour des raisons de sécurité! Tu rentres ton mot de passe et il t'ouvre un shell pour le root.
S'il n'ouvre pas l'interface graphique, il faut que tu executes xdm/kdm/gdm (en fonction du display manager qui tu as choisie).

Si tu veux créer un compte (ce qui est TRES fortement conseillé! pour des raisons de sécurité, il te faut un compte utilisateur que t'utilises tout le temps et le root uniquement pour gérer), utilise l'interface de Mandrake : DrakConf.

Pour résumé :

Login : root
mot de passe : (invisible)

$ kdm (pour lancer le X, c'est à dire l'interface graphique)

$ DrakConf (pour gerer linux et, entre autre, rajouter des utilisateurs)


edit : le demarrage en mode texte est une option durant l'install (quand tu configures le X, il te demande si tu veux lancer automatiquement le display manager au démarrage).
kenlesurvivant
ok merci je vais essaye de me debrouillé avec ça.en attendant.sauriez vous ou je pourrais trouver un tutos sur linstall la config et tout de mandrake???
Merci d'avance
Nova0_0
http://www.linux-france.org/article/index.html

http://www.mandrakelinux.com/fr/fdoc.php3

http://www.linux-center.org/fr/

etc, etc.

sur google il beaucoup (trop?) de pages parlant de ça....
kenlesurvivant
en fait je crois que je viens de trouver le probleme
lorsque j'installe mandrake,il me demande de choisir linterface graphique je choisi kde mais a un moment dant la config je vois dans materielle graphiqes "non configuré" donc je clique sur configurer et la je choisi ma carte graphique donc bah geforce6800 pour moi et l'ecran,la je dois choisir mon ecran,c'est celui de mon vieux pc donc un parkard bell 3070 et la je fais test et il me met error no device detected donc je pense que le probleme viens de la mais je sais pas comment le resoudre
Nova0_0
test avec un écran générique...
kenlesurvivant
c'est a dire?
kenlesurvivant
desolé de double poster mais petite question.crois tu que le probleme viens de la?
Temet_Nosce
Oui, il y a des chances.
Mets un écran générique de la bonne taille, vaut mieux que tu connaisses les fréquences de rafraichissement horizontale et verticale.
Nova0_0
QUOTE (kenlesurvivant @ 21/12/04 - 19:00)
desolé de double poster mais petite question.crois tu que le probleme viens de la?

s'il n'arrive pas au démarrage à lancer l'interface graphique (le X) oui il lance le mode texte...

Mais ça ne changera rien... si le X se lance, il te demandera quand même un login et un mot de passe (ou alors, il ouvrira automatiquement la session root, ce qui n'est pas une bonne chose point de vu sécurité...)

Pour ce qui est de l'écran générique, tout en haut du choix d'écran tu dois avoir VGA (ou generic) avec une liste d'écran sans nom (juste des fréquences et des résolutions...)

Si tu pouvais lancer une session root (en texte) et tapper la commande : "X& (ou kdm)"
S'il n'arrive pas à s'ouvrir il va te sortir un message d'erreur. Si c'est le cas, pourrais-tu recopier ici ce message?
kenlesurvivant
Alors je vous explique a nouveau.je vais tenter on va dire car meme moi je ne comprend pu trop.J'ai reinstallé a nouveau mandrake en creant compte mot de passe et tout.Mais au moment de la config du matos graphique,j'ai trouvé mon ecran dans la liste,le parckard bell pnp3070 donc je met dis maintenant que le probleme ne peux venir que de ma carte graphique mais pourtant j'ai une ASUSTeK V9999 - 128 Mo TV-Out/DVI (NVIDIA GeForce 6800) donc bah dans carte graphique je choisi geforce 6800 et quand je fais test il me dis nodevice detected.donc tant pis je termine l'instal et je redemarre.la comme d'hab il me sort le mode text donc je rentre mon login password et tout et une fois que j'ai fais ça je tape startx pour lancer l'interface graphique et la il me sort un message d'erreur comme si y'avais un probleme de config et qu'il ne reconnait pas mon materiel alors que j'ai bien parametrer mais a chaque fois il mettait no device detected.

Quelqu'un saura t'il m'aider
Nova0_0
le matos graphique est mal configuré.... L'erreur durant l'install et lorsque tu fais startx est la même....

qu'est-ce que tu as comme choix pour ta carte GeForce 6800? (c'est peut-être une ultra et le driver est pour GT).

Ce que tu peux faire c'est recupérer sur le site de nvidia les derniers drivers linux et les installer.


Tu peux reconfigurer le X sans re-installer mandrake avec DrakConf clindoeil.gif
kenlesurvivant
Oui j'ai trouvé drakconf.
le truc c'est que je ne sais absolument pas installé un drivers pour carte graphique dans linux et encore moins en mode texte.....
Autre chose lorsque je suis en train de configuré je ne peux choisir que Geforce6800(generic) il n'y a ni gt ni ultra etc...
Nova0_0
pour installer un driver sous linux c'est très simple clindoeil.gif

il suffit d'aller sur le site nvidia, récuperer le driver, le rapatrié sous linux, l'executer et suivre les instructions clindoeil.gif

Ce n'est que du mode texte.

tout est décrit sur le site de nvidia : http://www.nvidia.com/object/linux.html clindoeil.gif

http://www.nvidia.com/object/linux_display...2_1.0-6629.html pour l'accès directe (à moins que tu aies un athlon64, dans ce cas là c'est : http://www.nvidia.com/object/linux_display..._1.0-6629.html)
kenlesurvivant
J'ai un athlon 64 mais la version 32bit de linux car je n'ai pas trouvé la 64bit en version gratuite alors que la 32bit si
bon j'essaye ça et je vous dis quoi
kenlesurvivant
J'ai telecharger le driver et j'ai lu la notice pour l'installer mais pour l'installé je dois dire ou il est dans le disque dur,mais vu que je ne serais pu dans la partition windows dans laquelle le driver est mais dans la partition linux je ne vois pas comment je fais pour lui dire d'aller la chercher.
Je crois que j'ai vraimene du mal colere.gif
Nova0_0
tu dois pouvoir avoir accès à ta partition windows par /mnt/C ou /mnt/win_c ou /windows/C ou /mnt/--lettre de ton lecteur--, etc, etc.

Je te conseil de te créer un repertoire tmp sous root (mkdir tmp) et de la copier là... ("cp /mnt/C/Downloads/driver_nvidia_linux ~/tmp" avec le bon chemin clindoeil.gif ).
kenlesurvivant
bon je commence a comprendre je crois,comme tu m'a dis quand j'etais dans windows j'ai mis le drivers dans:
c/downloads/driver_nvidia_linux/
mais la en fait quand je redemarre avec linux. je tape donc /mnt/c/downloads/driver_nvidia_linux mais il me repond no such file in folder meme quand je met aussi le non du drivers qui est nvidia-linux-x86-1.0-6629-pkg1.run
donc je comprend pas trop,c'est pas ça que je devais faire normalement?
et quand j'essaye de taper mkdir tmp il me met file exist

Nova0_0
ok, alors commençons par la position des drivers.

Y a truc génial sous linux c'est la completion. En tappant le début d'un mot puis en appuyant sur tab il va essayer de finir le mot. J'explique. Par exemple pour une commande, tu tappes mkd, puis tab et il t'écrit mkdir bravo.gif S'il y a plusieur choix il bip et en rappuyant sur tab il te met la liste des choix possibles....
Et ça marche aussi avec les chemins!!! Par exemple tu tappes cd /mn puis tab, il te met cd /mnt/ puis tu rappuies sur tab, il te mets tous les sous-chemins possible et ainsi de suite.

pouceup.gif

Pour mkdir, oui, chui neuneu, sous root il y a déjà un repertoire tmp langue.gif

Si tu veux lister les fichiers dans un repertoire utilise ls ou ls -l

voilà
kenlesurvivant
donc logiquement si je tape le debut du chemin et ue je fais tab il va me trouver le drivers et la je n'aurai pu qu'a le choisir et faire "entrer" je pose la question car ça me semble trop facile pour marcher du premier coup
Nova0_0
voilà

et si ça marche pas tu fais deux tab plutot qu'un pour voir les possibilités clindoeil.gif
kenlesurvivant
Ca y est ca marche mais j'ai une nouvelle question ou vont les logiciels une fois installé car j'ai telechargé amule je l'ai installé mais je ne sais pas ou il se trouve!!!!!
Nova0_0
bravo.gif bravo.gif

Alors voici l'arborescence d'un systeme linux :

/bin : les executable
/dev : les "drivers"
/etc : les fichiers necessaires au bon fonctionnement des programmes.
/home : les comptes utilisateurs
/lib : les bibliothèques, les includes et quelques executables. (equivalent des DLL de windows)
/tmp : les fichiers temporaires
/usr : tout le reste (on y trouve des executables, des bibliotheques, des fichiers de configuration, etc, etc...)
/var : les variables (les logs par exemple).

Parfois, il y a aussi /opt qui est un /usr non rangé bigyellow.gif

Il a deux possiblité quand on installe un programme. Soit c'est fait par l'administrateur et c'est installé dans /lib et /usr. Soit c'est installé "en local" et dans ce cas là c'est dans /usr/local

Tu devrais rechercher des "guides pour débutants" sur le web qui expliquent les variables d'environnement, les commandes de base, les scriptes shell, l'arborescence, etc, etc. clindoeil.gif

edit : au fait, tout marche?
kenlesurvivant
Oui je te remercie pour l'instant ça vas a peu pres mais j'ai un probleme,j'ai telechargé amule et il me dis que j'ai une low id alors queJe prend ma connection internet sur un autre pc de la maison par reseaux local et que le parefeu est desactivé sur les 2ordinateurs
Nova0_0
ça c'est un problème avec ton logiciel et pas avec linux.... clindoeil.gif Désolé je ne peux pas t'aider...
kenlesurvivant
OK merci quand meme,c'est pas grave tu m'a deja bien aidé!!!
Ceci est une version "bas débit" de notre forum. Pour voir la version complète avec plus d'informations, la mise en page et les images, veuillez cliquer ici.