IPB
X   Message
(Message automatiquement fermé dans 2 secondes)

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
[Problème] Pas de son après la recompilation du noyeau
Iryshu
posté 08/03/2005, 19:20
Message #1


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Bonjour a tous,

Voilà j'ai recompilé le noyeau pour passer a la version 2.6.11 et allegé le noyeau de base de Debian (donc c'est la première fois que je le fait sur ce PC).
J'ai pas mal galleré mais finalment j'y suis arrivé mais petit problème, je n'ai pas de son.

Voilà ce que me donne lspci -v pour la carte son :
CODE
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
       Subsystem: ASRock Incorporation: Unknown device 7012
       Flags: bus master, medium devsel, latency 32, IRQ 10
       I/O ports at dc00 [size=256]
       I/O ports at d800 [size=128]
       Capabilities: [48] Power Management version 2


Donc j'ai configuré le noyau pour le chipset Sis 7012.
J'ai installé alsa et configuré avec alsaconf qui me détecte sans problème ma carte mais je n'ai toujours pas de son fou.gif .
Je regarde dans alsamixer et le canal Master est a 0 mais pas moyen de l'augmenter.
Dans kmix, il n'apparait même pas.

Je sais plus trop quoi faire, je suis complétment perdu, si quelqu'un savait m'aider.

Petitie présicion : Sur mon ancien noyau (2.6.8) le son fonctionne toujours sans problème.

Merci

Ce message a été modifié par Iryshu - 08/03/2005, 19:22.


--------------------
Iry'
Go to the top of the page
 
+Quote Post
pynux
posté 08/03/2005, 19:50
Message #2


Habitué
***

Groupe : Membres
Messages : 851
Inscrit : 26/02/05
Membre no 9058



je suis rester en 2.6.10 car le noyau 2.6.11 a quelque defaut , mais pas au niveau du son pour moi , c'est au niveau de la carte graph

downgrade a la 2.6.10 peu etre que ... sinon ta verifier si dans lsmod tu avais les driver de lancer ou que tu a activer le hotplug au demarrage dans ton kernel car sinon faut les monté a la main les module avec modprobe


--------------------
Image IPB
Go to the top of the page
 
+Quote Post
Iryshu
posté 08/03/2005, 22:01
Message #3


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Les drivers sont bien lancé.
Ce que me donne la commande lsmod | grep snd:
CODE
snd_intel8x0           33664  1
snd_ac97_codec         77368  1 snd_intel8x0
snd_pcm_oss            53664  0
snd_mixer_oss          20352  1 snd_pcm_oss
snd_pcm                95688  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26308  1 snd_pcm
snd_page_alloc          9988  2 snd_intel8x0,snd_pcm


Donc bon je crois qu'il y a tout, le driver snd_intel8x0 est bien lancé.

J'essayerai demain de voir avec la version 2.6.10 ou 2.6.8 pour voir si la sa marche.


--------------------
Iry'
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 09/03/2005, 00:31
Message #4


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Tiens, tu peux te faire un .deb de ton noyau : http://people.via.ecp.fr/~alexis/formation...yau-debian.html

comme ça t'as petit paquet (2.7 Mo pour moi) et tu peux l'installer et le désinstaller simplement, c super pratique!

Ce message a été modifié par Temet_Nosce - 09/03/2005, 00:32.


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
jacknaquunoeil
posté 09/03/2005, 09:05
Message #5


Amateur
*

Groupe : Membres
Messages : 26
Inscrit : 26/01/05
Membre no 8506



As-tu au moins du son en root ?
Go to the top of the page
 
+Quote Post
Nova0_0
posté 09/03/2005, 10:19
Message #6


GMP3 Fan
****

Groupe : Membres
Messages : 2009
Inscrit : 06/02/04
Lieu : Bordeaux
Membre no 2412



les versions impaires des noyaux sont des versions d'évaluations souvent truffées de bug en tout genre... Il est déconseillé de les installer et fortement conseillé de garder une version paire clindoeil.gif


--------------------
IFP 590 / Rio Karma

And deep beneath the rolling waves
In labyrinths of coral caves
The echo of a distant time
Comes willowing across the sand


Having an iPod is a totally different experience to any other audio digital device
Go to the top of the page
 
+Quote Post
jacknaquunoeil
posté 09/03/2005, 10:28
Message #7


Amateur
*

Groupe : Membres
Messages : 26
Inscrit : 26/01/05
Membre no 8506



QUOTE (Nova0_0 @ 09/03/05 - 10:19)
les versions impaires des noyaux sont des versions d'évaluations souvent truffées de bug en tout genre... Il est déconseillé de les installer et fortement conseillé de garder une version paire clindoeil.gif

Heu, oui, ce genre de choses est valable mais uniquement pour le deuxième chiffre, un 2.5.1 ou 2.7.1 est en effet en test mais les versions avec un chiffre pair en deuxième position comme 2.6 sont stables. clindoeil.gif
Go to the top of the page
 
+Quote Post
pynux
posté 09/03/2005, 13:11
Message #8


Habitué
***

Groupe : Membres
Messages : 851
Inscrit : 26/02/05
Membre no 9058



lol oui tu t'es gourer de chifre pour les paire et impaire mais c'est pas grave

sinon a tu du son en root car ca pourrai etre simplement que tu a pas les droi user sur /dev/dsp


--------------------
Image IPB
Go to the top of the page
 
+Quote Post
Iryshu
posté 09/03/2005, 15:52
Message #9


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Merci a tous de votre aide, finalment j'ai pris le noyau 2.6.8 et sa marche impec bigyellow.gif , je vais essayer avec le 2.6.10.

Aussinon j'ai une bète petite question, comment supprimer un ancien noyeau (le 2.6.11 quoi) si je ne suis pas passé par la méthode spécial pour débian (merci Temet_Nosce pour m'avoir fait découvrir cette méthode très pratique) ?


--------------------
Iry'
Go to the top of the page
 
+Quote Post
jacknaquunoeil
posté 09/03/2005, 16:54
Message #10


Amateur
*

Groupe : Membres
Messages : 26
Inscrit : 26/01/05
Membre no 8506



Bah, un sauvage rm /usr/src/linux-2.6.11 puis un rm des modules correspondant au noyau qui doivent être quelque part dans /usr/lib/modules/, désolé, je n'ai pas de linux sous la main, je ne me souviens plus du répertoire exactement.

Sinon, chtite question aussi, as-tu essayé de compiler ton 2.6.11 sans faire de ménage comme tu l'as dit plus haut ?

PS: pourquoi les TAB ne marchent pas sur le forum bigyellow.gif
Go to the top of the page
 
+Quote Post
Iryshu
posté 09/03/2005, 17:07
Message #11


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Merci de ton aide,

QUOTE (jacknaquunoeil @ 09/03/05 - 16:54)
Sinon, chtite question aussi, as-tu essayé de compiler ton 2.6.11 sans faire de ménage comme tu l'as dit plus haut ?

J'ai pas vraiment testé, mais je crois pas que sa aurai changé grand choses car j'ai repris le fichier de configuration du noyau 2.6.11 et sa a marché, sans aucune modification, avec le 2.6.8.

Je vais tester pour le suprimer comme ca, je croyait qu'il y'avait une méthode un peu moins "barbare".

Editer: Bon je viens de tester avec le noyau 2.6.10 avec le fichier de configuration du 2.6.8 et pas de son non plus fou.gif . J'ai bien verifié qu'il n'y avait pas de fonctions rajouté ou enlevé dans le noyau et j'ai rien trouver pour ce qui concerne le son.
Je crois que pour l'instant je vais rester sur la version 2.6.8 et attendre que les prochaines versions du noyau.

Ce message a été modifié par Iryshu - 09/03/2005, 19:20.


--------------------
Iry'
Go to the top of the page
 
+Quote Post
Pub
posté
Message #












Go to the top of the page
 
Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 09/12/2019 - 19:54