IPB
X   Message
(Message automatiquement fermé dans 2 secondes)

Bienvenue invité ( Connexion | Inscription )

 
Closed TopicStart new topic
[Question] Installer une Radeon 9600 Pro, Sous une agnula DeMuDi 1.2.1
Neolander
posté 18/11/2005, 20:47
Message #1


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



Alors après avoir creusé les possibilités de Mandrake de d'Ubuntu, je suis tombé sur Agnula DeMuDi (Distribution concue pour l'audio et la musique basées sur debian) et c'est le bonheur car tout fonctionne (même ma Gamesurround qui posait problème, avec 47 ms de latence qui plus est, contre 1243 (!) sous windoze).

Mais j'ai un problème de carte graphique.

Ma Radeon 9600 Pro n'est visiblement pas bien reconnue : j'ai dû installer un driver générique (vesa je crois) pour la faire fonctionner et ça marche en 60 Hz, ce qui n'est pas terrible.

Il s'agit donc d'installer un driver à l'origine concu pour mandrake sous une distribution linux qui semble même pas avoir de compilateur.
De plus, je n'ai pas internet sur mon pc perso (où est linux) mais sur le pc de mon père où je suis actuellement (bien que je le boote sous linspire de temps en temps) donc les apt-get bien pratiques, je peux leur dire au revoir.

J'ai utilisé une commande spéciale à l'installation pour avoir le kernel 2.6.12-3.
(Avec un suffixe -multimedia-k7 auquel je ne comprend rien)

Où chercher pour résoudre ce problème ???


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Basaltinou
posté 18/11/2005, 20:52
Message #2


GMP3 Addict
*****

Groupe : Membres
Messages : 26341
Inscrit : 17/12/03
Lieu : Viry Chatillon (91)
Membre no 1304



Tu as les drivers ici

A toi de choisir selon que tu aies du 64 bits ou pas Sourire.gif


--------------------
Plus connu sous le pseudonyme de "diablo"

Baladeur mp3 : Cowon D2 16 Go noir
Casques : Ultimate Ears Super.Fi 5, Sennheiser HD 25-1 II, Sennheiser HD515
Go to the top of the page
 
+Quote Post
Neolander
posté 18/11/2005, 21:18
Message #3


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



Oui... mais c'est des RPM...
Redhat Package Manager...

Donc pour une debian...

J'ai trouvé également un site qui fournit des drivers, mais l'installation fait peur (recompiler le noyau, risque de bug total du serveur graphique... gaspe !)

De plus, mon linux n'utilise pas "startx" mais "gdm" pour connecter l'interface graphique. Il semblerait que ce soit un serveur graphique autre que XFree/X.Org. Il doit probablement y avoir une raison pour qu'ils n'aient pas mis X.Org, autre que l'originalité !


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 23/11/2005, 13:49
Message #4


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Houla houla houla.....

Alors gdm n'a AUCUN rapport avec Xorg (ou XFree pour les distris à la ramasse comme Debian stable).
GDM, c'est juste Gnome Display Manager ... mais ça sert juste grosso merdo à gérer tes sessions sous X.
Perso j'utilise KDM, mieux adapté à KDE.
Il y aussi XDM qui est tout moche.

Alors ton problème, c'est un peu le problème des distributions exotiques ... t'as rien sous la main...

D'autre part, faut dire ce qui est, les drivers d'ATI pour linux, c'est de la merde. De ce coté là, les dev nvidia se soucient bien plus de leurs utilisateurs linuxiens... et les linuxiens le leur rendent bien (par exemple, quand on me demande, je déconseille vivement ATI).

Je n'ai jamais installé de drivers ATI, mais je pense que tu peux certainement installer GCC s'il ne l'est pas par défaut (y a que Ubuntu que j'ai vu oser faire une telle infamie), et donc certainement compiler le module pour ta carte. Le module n'est pas le noyau. Ca a l'air compliqué dit comme ça, mais y a une grosse année, je faisais comme ça pour les drivers nvidia et quand tu l'as fait une fois, ça prend 2 minutes à tout casser.


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
Neolander
posté 23/11/2005, 20:43
Message #5


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



Ah ok...

Je devais confondre avec XDM...
Le lanceur de mandrake...

Mais sur ce site proposant un binary debian, ils parlaient bien d'avoir les sources du NOYAU et de le recompiler là je me suis pas planté...


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 24/11/2005, 10:38
Message #6


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Le lanceur de mandrake n'est certainement xdm, mais kdm ou gdm (je pencherais pour kdm, kde étant son desk par défaut).

En ce qui concerne le module pour ta carte, il te faut les headers du noyau, les sources du noyau ne sont plus nécessaires aujourd'hui. Néanmoins, vu que Debian est toujours à la bourre, il n'est pas impossible que tu aies besoin des sources du noyau, mais pas pour compiler ton noyau, mais pour compiler le module! En effet, un module a besoin au minimum des headers du noyau pour se compiler.

Hope this helps.


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
Neolander
posté 26/11/2005, 14:31
Message #7


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



Après avoir vu gdm sous ubuntu et agnula je pense finalement que c'est kdm qui est présent...

Toujours est il que GCC 3.3 est-ce suffisant aujourd'hui ? Parce que la dernière version (4.0.2 je crois) pèse quand même 40 Mo à la download...

Je crois que j'ai les headers du noyau, il va falloir que j'aille fouiller dans synaptic...

(Vache ! 3 bourdes en 2 posts ! J'ai battu mon record là !)

1- http://xoomer.virgilio.it/flavio.stanchina...-installer.html : L'installation n'a pas l'air de briller par sa simplicité... et tous les howto que je trouve c'est avec apt-get... quelqu'un saurait comment faire pour moi ?


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 27/11/2005, 15:03
Message #8


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Il te faut la même version de GCC que celle qui a compilé ton noyau il me semble... donc celle par défaut c'est bien. Et Gcc4, pour le moment... oublie.
Sinon non, je ne saurais pas comment faire que je n'ai jamais eu d'ATI, et compte ne jamais en avoir ^^


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
Neolander
posté 02/12/2005, 10:12
Message #9


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



J'ai réussi à installer ce basar et c'était pas si compliqué en fait...

(J'avais pas vu un lien ati vers une version non-rpm... frown.gif 60 Mo quand même !)

Mais j'arrive toujours pas à compiler par ailleurs mes autres progs...

Alors donc à priori [Résolu] mais je vais ptêt créer un topic sur mes problèmes de compilation (les scripts "configure" ne trouvent pas de compilateurs)


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Nicholas
posté 02/12/2005, 11:01
Message #10


Pré-retraité
****

Groupe : Retraités équipe GMP3
Messages : 9486
Inscrit : 19/01/05
Lieu : Hassy s/ Machèse
Membre no 8344



Je ferme, donc.


--------------------
Go to the top of the page
 
+Quote Post
Pub
posté
Message #












Go to the top of the page
 
Quote Post

Closed TopicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 08/12/2019 - 01:56