IPB
X   Message
(Message automatiquement fermé dans 2 secondes)

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
[FreeBSD] Mettre à jour les logiciels pré-compilé.
Iryshu
posté 05/04/2005, 19:53
Message #1


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Bonjour a tous,

Voilà j'ai installé la version 5.3 de FreeBSD et en fet je trouve les paquets trop vieux (firefox est en version 0.93 et kde en 3.3.0).
Donc j'ai un peu cherchez comment mettre a jour tous sa mais j'ai que trouvé pour les logiciels portés (a compiler quoi).
La il faut uttilisé cvsup puis portudate, mais pour les logiciel pré-compilé j'ai pas trouvé.

Un autre petite question, j'ai vu que on pouvais installer les logiciels en précisant l'adresse ou le trouver avec pkg_add (pkg_add -r http://url/log.tbz).
Mais je me demande comment définir cette adresse comme adresse par défaut pour avoir donc les paquets les plus récent.

Merci de votre aide Sourire.gif


--------------------
Iry'
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 06/04/2005, 04:26
Message #2


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Oula, pas sur que tu trouves des FreeBSDistes ici... bonne chance! clindoeil.gif


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
Iryshu
posté 06/04/2005, 11:12
Message #3


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



On peut toujours espérer langue.gif

Mais je crois que j'ai trouvé un début de réponse :

QUOTE
2.3 Mettre à jour  une application que vous avez installé via les packages

La différence est la suivante entre les ports et les packages. Un package est une application déjà compilée. On a donc les binaires, et non pas les sources. Cela vous évite d'avoir à faire la compile vous même. Les packages se trouvent sur le ftp  d'OpenBSD. Vous les installez avec un pkg_add nom_du_package.

La meilleure façon pour faire une mise à jour consiste à enlever le package (pkg_delete) et à le réinstaller en utilisant le package que l'on peut trouver sur le ftp d'OpenBSD. Attention à bien faire une copie de vos fichiers de configuration avant de faire cette opération.
En fait il n'existe pas de pkg_update (apt-get update ??) sous OpenBSD. Vous n'avez donc pas trop de choix que de supprimer et de réinstaller.

La question est bien sur comment savoir qu'il faut mettre à jour une application.
- D'abord en connaissant la version que vous avez installé.
- En surveillant les problèmes de sécurité qui surviennent aux applications que vous avez installé. N'est ce pas l'un des rôles le plus important de l'administrateur systéme.
- En regardant dans /usr/ports/INDEX les différences de version.


Voilà ce que j'ai trouvé sur un site parlant de openbsd et comme freebsd est très proche, je crois que ce que je veux faire est impossible frown.gif.
Je suis obligé de désinstaller le logiciel et puis le réinstaller, ou le faire via cvsup, mais la il me compile tout.

Ce message a été modifié par Iryshu - 06/04/2005, 11:13.


--------------------
Iry'
Go to the top of the page
 
+Quote Post
Nova0_0
posté 08/04/2005, 08:44
Message #4


GMP3 Fan
****

Groupe : Membres
Messages : 2009
Inscrit : 06/02/04
Lieu : Bordeaux
Membre no 2412



les paquets, ce sont des RPM? parceque là c'est facile clindoeil.gif

Sinon, tu peux tout simplement supprimer les logiciels qui sont trop vieux et installer les nouveaux clindoeil.gif


--------------------
IFP 590 / Rio Karma

And deep beneath the rolling waves
In labyrinths of coral caves
The echo of a distant time
Comes willowing across the sand


Having an iPod is a totally different experience to any other audio digital device
Go to the top of the page
 
+Quote Post
Iryshu
posté 08/04/2005, 11:30
Message #5


Connaisseur
**

Groupe : Membres
Messages : 316
Inscrit : 03/08/04
Membre no 5211



Non ce ne sont pas des paquets RPM comme sur la mandrake, en fet je sais pas vraiment l'extension des paquets précomilé chez FreeBSD.

Suprimer les vieux logiciel et retélécharger les nouveaux est quand même assez fastidieux et il faudra aller voir si il y a des nouvelles version, ce qui est assez embétant.


Je crois que je vais laisser tombé les distribution BSD et retourné sous Linux.

Ce message a été modifié par Iryshu - 08/04/2005, 11:31.


--------------------
Iry'
Go to the top of the page
 
+Quote Post
Pub
posté
Message #












Go to the top of the page
 
Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 13/12/2019 - 07:02