IPB
X   Message
(Message automatiquement fermé dans 2 secondes)

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
[Information] Procedure d'installation d'un baladeur mp3, sur linux evidement
william
posté 01/01/2004, 14:55
Message #1


Amateur
*

Groupe : Membres
Messages : 21
Inscrit : 28/12/03
Membre no 1539



Procédure à suivre pour installer un baladeur mp3 sur linux (ou autre mémoire amovible branché sur un usb) en tant que mémoire amovible (Mass Storage Device). Personnellement j'ai fait ca pour mon baladeur mp3 iRiver 390T utilisant firmware UMS (pour tout les baladeurs mp3 iRiver, il faut nécessairement le firmware UMS). Mais je ne parlerai pas spécifiquement de ce baladeur mp3. Cependant il faut que le baladeur mp3 puisse être considéré comme un périphérique de mémoire amovible, il faut donc que le firmware de votre lecteur mp3 soit adéquat. Et qu'il soit partitionné en fat (ils le sont tous peut être ?)

Règle importante : lire toute la procédure entièrement avant de commencer toute opération.

Le baladeur mp3 est considéré comme de la mémoire, comme un disque. Sous windows tout est fait automatiquement (et donc soit reconnaît, soit ne reconnaît pas le baladeur) sans qu'on ne puisse rien y faire. Sous linux il va falloir faire cela manuellement, donc en contrôlant tout ce qui se passe, par conséquent se rendre compte des problèmes que l'on peut rencontrer et donc les résoudre. Sur certaines distributions récentes (mandrake 9.0 et plus), il vous suffit de brancher votre lecteur sur l'usb et de monter.
# mount /mnt/removable
Cependant je vous invite a ne par faire comme cela et a configurer une bonne fois pour toute votre lecteur.
Tout d'abord il s'agit de savoir si vous avez les 2 modules indispensables : usb-uchi (ou usb-ochi, selon votre USB) et le module de stockage usb-storage. Pour cela tapez lsmod en étant root. (lsmod indique les modules chargés)
# lsmod
Vérifiez s'ils sont bien dans la liste, si ce n'est pas le cas il va falloir charger le ou les manquant. Dans ce cas :
# modprobe usb-uchi
# modprobe usb-storage
Si ca ne marche pas pour usb-uchi, essayez avec usb-ochi, cela dépend de votre USB.

Une fois que les modules sont chargés vous pouvez brancher votre baladeur mp3 sur votre USB.

Tapez dmesg dans la console pour voir si votre baladeur est reconnu. S'il est reconnu ceci devrait apparaître, mais pas exactement pareil selon votre baladeur (dans mon cas un iRiver), si vous avez déjà des périphériques USB etc... :

scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: iRiver Model: iFP Mass Driver Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 512000 512-byte hdwr sectors (262 MB)
sda: Write Protect is off
/dev/scsi/host1/bus0/target0/lun0: p1 p2 p3 p4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 4


Si ca ne marche pas vérifiez que vous avez bien les modules nécessaires (voir précédemment).
Le baladeur mp3 est reconnu comme un disque dur scsi, le nom qui lui est assigné est sda, mais il peut aussi bien être sdb si vous avez déjà quelque chose d'autre assigné a sda. Il faut maintenant monter sda ou sdb, c'est a dire accéder au lecteur mp3. Pour cela, il faut éditer le fichier /etc/fstab et rajouter la ligne suivante :
/dev/sda /mnt/ifp vfat defaults,user,exec,nosuid,noauto 0 0
Ceci est ce que j'ai rajouté personnellement, vous pouvez y faire quelques modifications :
- mettre /dev/sdb a la place de /dev/sda si votre lecteur est assigné comme sdb (ou autres)
- /mnt/ifp : ifp est simplement le modèle de mon baladeur mp3, vous pouvez mettre ce que vous voulez (/mnt/mp3 ; /mnt/iriver ; /mnt/ibead etc...).

Derniàre étape avant de pouvoir utiliser votre baladeur mp3 correctement, créer le dossier /mnt/ifp (dans mon cas, dans le votre créez le dossier que vous avez indiqué dans fstab)
# mkdir /mnt/ifp

Il vous suffit maintenant de monter ifp pour accéder a votre baladeur mp3. (sans avoir besoin d'être root)
$ mount /mnt/ifp
Vous pouvez maintenant accéder aux fichiers de votre lecteur mp3, faire des transferts etc...
Une fois que vous avez fini vos opérations, n'oubliez jamais de démonter.
$ umount /mnt/ifp

Une petite astuce, une fois que vous avez monté le dossier de votre baladeur mp3, utilisez la commande suivante pour ouvrir votre explorateur de fichier avec le dossier monté. (a faire dans la console juste après que vous avez fait la commande pour monter dans votre dossier ; et n'oubliez pas de démonter une fois que vous avez fini, car fermer le programme ne suffira pas, il faudra faire la commande pour démonter).
$ nom_de_lexplorateur /mnt/nomdudossier
ce qui donne dans mon cas :
$ konqueror /mnt/ifp


Pour réaliser cet article je me suis inspire d'un article du forum de iriver.com et du site lea-linux.org

Il y a sûrement des choses à changer et à améliorer dans cet article, si vous y trouvez des erreurs, problèmes, modifications à faire, n'hésitez pas a m'envoyer un email. Vous pouvez également m'envoyer vos questions auxquels je répondrai dans la mesure du possible. Voilà !

williambrown@wanadoo.fr

Ce message a été modifié par bigouz - 01/03/2005, 22:07.
Go to the top of the page
 
+Quote Post
neo spank
posté 01/01/2004, 15:22
Message #2


GMP3 Fan
****

Groupe : Membres
Messages : 3203
Inscrit : 25/10/03
Lieu : nord (59)
Membre no 621



bravo, vraiment c'est super.


--------------------
user posted image

Go to the top of the page
 
+Quote Post
ghost
posté 01/01/2004, 15:35
Message #3


GMP3 Fan
****

Groupe : Membres
Messages : 1295
Inscrit : 01/11/03
Membre no 675



Super travail William IPB Image

Je demande à Boogie de l'épingler, nos "supers pouvoirs" sont inactifs dans cette section.

A+ clindoeil.gif


--------------------
Je suis mort un 26 février... et tel le phoenix, je renais de mes cendres. Tant que j'aurais des rêves, le phoenix ne mourra pas.

_______________________________________________________

Mon site de photos: http://www.emarin-photos.fr
Go to the top of the page
 
+Quote Post
boogieplayer
posté 01/01/2004, 19:21
Message #4


GMP3 Fan
****

Groupe : Collector
Messages : 3229
Inscrit : 19/06/03
Membre no 385



Splendide. Sourire.gif


--------------------
Go to the top of the page
 
+Quote Post
GeO
posté 14/01/2004, 18:39
Message #5


Amateur
*

Groupe : Membres
Messages : 34
Inscrit : 13/01/04
Lieu : Paris
Membre no 1943



william ce heros... clindoeil.gif

Merci beaucoup pour cette aide qui a bien limité mes problèmes...

Un petit ajout pas forcément nécessaire mais autant le dire : il faut également compiler 2 modules pour l'emulation scsi (sachant que le noyau standard de toutes les distributions les intègrent par defaut, soit en module soit compilé directement dans le noyau) : scsi_mod, sd_mod

Je conseille également l'option sync dans le fichier /etc/fstab, ce qui force linux à transferer les fichiers immédiatement, et qui évite un temps d'attente toujours bizarre au moment du démontage du repertoire

Je constate la presence dans la sortie de dmesg de pas mal de messages d'erreur, ce qui n'empeche pas de copier des fichiers mais me fait dire que tout ne marche pas nickel :
Code
usb-storage: queuecommand() called
usb-storage: *** thread awakened.
usb-storage: Command READ_10 (10 bytes)
usb-storage: 28 00 00 00 00 a0 00 00 01 00 00 00
usb-storage: Bulk command S 0x43425355 T 0x55 Trg 0 LUN 0 L 512 F 128 CL 10
usb-storage: Bulk command transfer result=0
usb-storage: usb_stor_transfer_partial(): xfer 512 bytes
usb-storage: usb_stor_bulk_msg() returned 0 xferred 512/512
usb-storage: usb_stor_transfer_partial(): transfer complete
usb-storage: Bulk data transfer result 0x0
usb-storage: Attempting to get CSW...
usb-storage: Bulk status result = 0
usb-storage: Bulk status Sig 0x53425355 T 0x55 R 0 Stat 0x0
usb-storage: scsi cmd done, result=0x0
usb-storage: *** thread sleeping.

Ce message se repete un certain nombre de fois ; visiblement l'appel de la fonction queuecommand() est pas genial...

Autre souci, le contenu de mon repertoire voice qui est le suivant :
Code
total 1536
drwxr--r--    4 geo      users       16384 1980-01-01 00:00 .
drwxr--r--    6 geo      users       16384 2004-01-14 18:29 ..
-rwxr--r--    1 geo      users         175 1988-01-01 00:00 é
-rwxr--r--    1 geo      users     1396224 1980-01-01 00:00 ifp-3xxt.hex
-rwxr--r--    1 geo      users       65535 1980-01-14 00:00 øÿÿÿÿÿÿÿ.?
-rwxr--r--    1 geo      users        8224 2004-10-20 09:10 qï?
drwxr--r--    2 geo      users       16384 1980-01-01 00:00 record
drwxr--r--    4 geo      users       16384 1980-01-01 00:00 voice

On remarque qu'il contient record et voice de nouveau, ainsi que des fichiers chelous... Le pire c'est que le repertoire voice inclus a lui aussi la meme composition... bref c'est un puits sans fond !!!!

Si quelqu'un pouvait m'eclairer sur ces 2 soucis...

Pour terminer, je signale l'existence d'un driver linux pour iFP qui permet d'utiliser les iRiver sous Linux avec le firmwire Manager quoi.gif ca torche non ? j'ai pas fini de tout lire, notamment les messages de la mailing-liste, mais ca a l'air prometteur et intéressant :
http://ifp-driver.sourceforge.net/
Go to the top of the page
 
+Quote Post
william
posté 15/01/2004, 18:24
Message #6


Amateur
*

Groupe : Membres
Messages : 21
Inscrit : 28/12/03
Membre no 1539



Je connaissais l'existence de ce programme, mais je l'ai jamais utilise. Je trouve ca plus pratique en UMS personellement... Mais sinon tu as essaye ce programme ?

En ce qui concerne le fichier voice, j'ai jamais regarde dedans, peut etre est-ce la meme chose sous windows ? j'en sais rien...

En ce qui concerne sync pour le fstab, tres bonne idee !! je pense pas qu'il y ai d'endroit precis ou mettre cette option, dans la liste entre deux virgules, genre
/dev/sda /mnt/ifp vfat defaults,sync,user,exec,nosuid,noauto 0 0
si tu pouvais confirmer ?

Content que ce petit article que j'ai ecrit t'ai aide... !

et merci de vos remerciements !

Ce message a été modifié par william - 15/01/2004, 18:25.
Go to the top of the page
 
+Quote Post
GeO
posté 16/01/2004, 18:38
Message #7


Amateur
*

Groupe : Membres
Messages : 34
Inscrit : 13/01/04
Lieu : Paris
Membre no 1943



Citation
Je connaissais l'existence de ce programme, mais je l'ai jamais utilise. Je trouve ca plus pratique en UMS personellement... Mais sinon tu as essaye ce programme ?

En fait non, je ne trouve que des défauts au firmwire Manager (avis perso bien sûr), hormis la sauvegarde de stations de radios...

Pour mon repertoire VOICE, il apparait bien comme il faut sous Windows, vide... Donc si quelqu'un a une idée du pb ???? fou.gif

je confirme, tu peux mettre le sync où tu veux dans les options, ca n'a pas d'importance. Comme tu le suggères c'est nickel... jap.gif
Go to the top of the page
 
+Quote Post
Nova0_0
posté 06/02/2004, 21:07
Message #8


GMP3 Fan
****

Groupe : Membres
Messages : 2009
Inscrit : 06/02/04
Lieu : Bordeaux
Membre no 2412



c'est marrant, mais moi, pour monter une clé usb, je faisais tout simplement :

mount -tvfat -oumask=0000 /dev/sda1 /mnt/usbkey

bon, c'est pareil que de passer par /etc/fstab, mais j'utilise sda1, et non pas sda...

(pour ce que ça change.... rolleyes.gif )


--------------------
IFP 590 / Rio Karma

And deep beneath the rolling waves
In labyrinths of coral caves
The echo of a distant time
Comes willowing across the sand


Having an iPod is a totally different experience to any other audio digital device
Go to the top of the page
 
+Quote Post
o.v.n.i
posté 01/06/2004, 21:13
Message #9


Nioubiz


Groupe : Membres
Messages : 2
Inscrit : 31/05/04
Membre no 4234



bonjour tt le monde...
g une lecteur mp3 iriver 390T et mandrake linux 10.0. g bien suivi le tuto pr faire marcher mon lecteur mais je n'arrive pas a charger usb-uchi ou usb-ochi il me dit:
[root@dhcppc2 root]# modprobe usb-uchi
FATAL: Module usb-uchi not found.
lsmod :

Code
[root@dhcppc2 firefox]# lsmod
Module                  Size  Used by
DAC960                 72936  0
usb-storage            72932  0
udf                    94660  0
sg                     38044  0
st                     38616  0
sr_mod                 17028  0
sd_mod                 16832  0
scsi_mod              114648  5 usb-storage,sg,st,sr_mod,sd_mod
nfsd                  173152  8
exportfs                5920  1 nfsd
radeon                127008  36
parport_pc             32832  1
lp                     12200  0
parport                38952  2 parport_pc,lp
md5                     3872  1
ipv6                  232352  12
snd-seq-midi            8160  0
snd-emu10k1-synth       6816  0
snd-emux-synth         36320  1 snd-emu10k1-synth
snd-seq-virmidi         6912  1 snd-emux-synth
snd-seq-midi-emul       7776  1 snd-emux-synth
snd-seq-oss            31232  0
snd-seq-midi-event      7552  3 snd-seq-midi,snd-seq-virmidi,snd-seq-oss
snd-seq                51024  8 snd-seq-midi,snd-emux-synth,snd-seq-virmidi,snd-seq-midi-emul,snd-seq-oss,snd-seq-midi-event
snd-pcm-oss            51812  1
snd-mixer-oss          17952  1 snd-pcm-oss
snd-emu10k1            85508  3 snd-emu10k1-synth
snd-rawmidi            23616  3 snd-seq-midi,snd-seq-virmidi,snd-emu10k1
snd-pcm                93156  2 snd-pcm-oss,snd-emu10k1
snd-timer              24484  2 snd-seq,snd-pcm
snd-seq-device          8008  7 snd-seq-midi,snd-emu10k1-synth,snd-emux-synth,snd-seq-oss,snd-seq,snd-emu10k1,snd-rawmidi
snd-ac97-codec         58148  1 snd-emu10k1
snd-page-alloc         11972  2 snd-emu10k1,snd-pcm
snd-util-mem            4448  2 snd-emux-synth,snd-emu10k1
snd-hwdep               8928  2 snd-emux-synth,snd-emu10k1
snd                    52484  18 snd-seq-midi,snd-emux-synth,snd-seq-virmidi,snd-seq-oss,snd-seq-midi-event,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-emu10k1,snd-rawmidi,snd-pcm,snd-timer,snd-seq-device,snd-ac97-codec,snd-util-mem,snd-hwdep
soundcore               9248  2 snd
af_packet              20520  2
hid                    53312  0
ide-floppy             18752  0
ide-tape               34864  0
ide-cd                 40548  0
cdrom                  37184  2 sr_mod,ide-cd
floppy                 59444  0
8139too                23712  0
mii                     4992  1 8139too
nls_iso8859-15          4480  2
nls_cp850               4736  2
vfat                   13760  2
fat                    45120  1 vfat
supermount             37876  3
via-agp                 7360  1
agpgart                31016  2 via-agp
uhci-hcd               29104  0
usbcore                99132  5 usb-storage,hid,uhci-hcd
rtc                    11576  0
[root@dhcppc2 firefox]#


puis dmesg:
Code
[root@dhcppc2 firefox]# dmesg
Linux version 2.6.3-7mdk (nplanel@n3.mandrakesoft.com) (gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)) #1 Wed Mar 17 15:56:42 CET 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000bff0000 (usable)
BIOS-e820: 000000000bff0000 - 000000000bff3000 (ACPI NVS)
BIOS-e820: 000000000bff3000 - 000000000c000000 (ACPI data)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
191MB LOWMEM available.
On node 0 totalpages: 49136
 DMA zone: 4096 pages, LIFO batch:1
 Normal zone: 45040 pages, LIFO batch:10
 HighMem zone: 0 pages, LIFO batch:1
DMI 2.2 present.
ACPI disabled because your bios is from 00 and too old
You can enable it with acpi=force
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=linux ro root=346 devfs=mount acpi=ht resume=/dev/hdb5 splash=silent
bootsplash: silent mode.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 551.288 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Memory: 190612k/196544k available (1816k kernel code, 5292k reserved, 849k data, 272k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 1085.44 BogoMIPS
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 52k freed
CPU:     After generic identify, caps: 0387fbff 00000000 00000000 00000000
CPU:     After vendor identify, caps: 0387fbff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU serial number disabled.
CPU:     After all inits, caps: 0383fbff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Pentium III (Katmai) stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 551.0184 MHz.
..... host bus clock speed is 100.0215 MHz.
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xfb380, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040211
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
PnPBIOS: Disabled
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router VIA [1106/0596] at 0000:00:07.0
vesafb: framebuffer at 0xd8000000, mapped to 0xcc800000, size 16384k
vesafb: mode is 800x600x16, linelength=1600, pages=135
vesafb: protected mode interface info at c000:56f5
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
fb0: VESA VGA frame buffer device
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
ikconfig 0.7 with /proc/config*
VFS: Disk quotas dquot_6.5.1
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Initializing Cryptographic API
Activating ISA DMA hang workarounds.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
bootsplash 3.1.4-2004/02/19: looking for picture.... silentjpeg size 14856 bytes, found (800x600, 14808 bytes, v3).
Console: switching to colour frame buffer device 92x32
pty: 1024 Unix98 ptys configured
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:07.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c596b (rev 12) IDE UDMA66 controller on pci0000:00:07.1
   ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:DMA
   ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:pio
hda: Maxtor 91021U2, ATA DISK drive
hdb: WDC WD400BB-00CFC0, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: Hewlett-Packard CD-Writer Plus 9500, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 20010816 sectors (10245 MB) w/512KiB Cache, CHS=19852/16/63, UDMA(66)
/dev/ide/host0/bus0/target0/lun0: p1
hdb: max request size: 128KiB
hdb: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(66)
/dev/ide/host0/bus0/target1/lun0: p1 p2 < p5 p6 p7 p8 >
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: ImExPS/2 Generic Explorer Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
EISA: Probing bus 0 at eisa0
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET: Registered protocol family 1
BIOS EDD facility v0.13 2004-Mar-09, 2 devices found
Please report your BIOS at http://linux.dell.com/edd/results.html
Resume Machine: resuming from /dev/hdb5
Resuming from device hdb5
Resume Machine: This is normal swap space
PM: Reading pmdisk image.
PM: Resume from disk failed.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
Mounted devfs on /dev
Freeing unused kernel memory: 272k freed
Real Time Clock Driver v1.12
drivers/usb/core/usb.c: registered new driver usbfs
drivers/usb/core/usb.c: registered new driver hub
drivers/usb/host/uhci-hcd.c: USB Universal Host Controller Interface driver v2.1
PCI: Found IRQ 10 for device 0000:00:07.2
PCI: Sharing IRQ 10 with 0000:00:0b.0
uhci_hcd 0000:00:07.2: UHCI Host Controller
uhci_hcd 0000:00:07.2: irq 10, io base 0000d400
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Adding 610428k swap on /dev/hdb5.  Priority:-1 extents:1
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected VIA Apollo Pro 133 chipset
agpgart: Maximum main memory to use for agp memory: 149M
agpgart: AGP aperture is 64M @ 0xe8000000
Supermount version 2.0.4 for kernel 2.6
8139too Fast Ethernet driver 0.9.27
PCI: Found IRQ 10 for device 0000:00:0b.0
PCI: Sharing IRQ 10 with 0000:00:07.2
eth0: RealTek RTL8139 at 0xcd91f000, 00:e0:7d:98:3c:58, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8139C'
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (1535 buckets, 12280 max) - 300 bytes per conntrack
inserting floppy driver for 2.6.3-7mdk
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
hdc: ATAPI 32X CD-ROM CD-R/RW drive, 4096kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
drivers/usb/core/usb.c: registered new driver hiddev
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
NET: Registered protocol family 17
eth0: link up, 10Mbps, half-duplex, lpa 0x0000
PCI: Found IRQ 11 for device 0000:00:0c.0
NET: Registered protocol family 10
Disabled Privacy Extensions on device c035fe60(lo)
IPv6 over IPv4 tunneling driver
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
lp0: using parport0 (polling).
lp0: console ready
mtrr: 0xd8000000,0x8000000 overlaps existing 0xd8000000,0x1000000
[drm] Initialized radeon 1.10.0 20020828 on minor 0: ATI Radeon RV280 9200 SE
mtrr: 0xd8000000,0x8000000 overlaps existing 0xd8000000,0x1000000
agpgart: Found an AGP 1.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
[drm] Loading R200 Microcode
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
eth0: no IPv6 routers present
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 0 changed to on
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 1 changed to on
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 2 changed to on
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 3 changed to on
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 4 changed to on
bootsplash 3.1.4-2004/02/19: looking for picture.... found (800x600, 11943 bytes, v3).
bootsplash: status on console 5 changed to on
SCSI subsystem initialized
st: Version 20040122, fixed bufsize 32768, s/g segs 256
end_request: I/O error, dev fd0, sector 0
udf: registering filesystem
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Initializing USB Mass Storage driver...
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.
usb 1-2: new full speed USB device using address 2
[root@dhcppc2 firefox]#


voila si qqn pourrai m'aider svp... bonjour.gif

Ce message a été modifié par o.v.n.i - 02/06/2004, 12:54.
Go to the top of the page
 
+Quote Post
Struddel
posté 01/06/2004, 22:27
Message #10


GMP3 Fan
****

Groupe : Membres
Messages : 5983
Inscrit : 02/12/03
Lieu : Angers
Membre no 1024



et ca marche pas ? avec la fin du code on dirait que ça marche lol.

Citation
Initializing USB Mass Storage driver...
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.
usb 1-2: new full speed USB device using address 2
[root@dhcppc2 firefox]#


Au fait pourquoi le monter une fois pour toutes ?

Moi j'ai fait # mount /mnt/removable et maintenant ça marche chaque fois que je lance linux lol

Ce message a été modifié par Struddel - 01/06/2004, 22:29.


--------------------
Je suis parfaitement improbable

Baladeurs : Archos 5 3G+ - Archos 5 - Archos 404 - Archos Gmini 200

Casques : Shure e2c - SkullCandy crushers - Koss KSC 55 - Koss the plug - Motorola HT820 - Creative Zen intra
Go to the top of the page
 
+Quote Post
o.v.n.i
posté 02/06/2004, 19:04
Message #11


Nioubiz


Groupe : Membres
Messages : 2
Inscrit : 31/05/04
Membre no 4234



Citation (Struddel @ 01/06/04 - 22:27)
et ca marche pas ? avec la fin du code on dirait que ça marche lol.

Citation
Initializing USB Mass Storage driver...
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.
usb 1-2: new full speed USB device using address 2
[root@dhcppc2 firefox]#


Au fait pourquoi le monter une fois pour toutes ?

Moi j'ai fait # mount /mnt/removable et maintenant ça marche chaque fois que je lance linux lol

non, ca marche pas...
et quand j'essaie de monter /mnt/removable :
Citation
[root@dhcppc2 firefox]# mount /mnt/removable
mount: ne peut repérer /mnt/removable dans /etc/fstab ou /etc/mtab
[root@dhcppc2 firefox]#

.... frown.gif
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 02/06/2004, 23:42
Message #12


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Monte le en user et pas en root.

Si ca marche pas, tente la manip de Nova :

mount /dev/sda1 /mnt/removable

Ce message a été modifié par Temet_Nosce - 02/06/2004, 23:44.


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
pynux
posté 01/03/2005, 22:02
Message #13


Habitué
***

Groupe : Membres
Messages : 851
Inscrit : 26/02/05
Membre no 9058



bizard ton fstab ou ton /dev

car moi /dev/sda existe certe
mais je met '/dev/sda1 /mnt/M3-20Go vfat noauto,nosuid,users,sync,exec 0 0'

dans mon fstab (pour avoir la partition 1 langue.gif)

(ps je suis sur slackware-current )

Ce message a été modifié par pynux - 01/03/2005, 22:06.


--------------------
Image IPB
Go to the top of the page
 
+Quote Post
Neolander
posté 26/11/2005, 15:18
Message #14


Habitué
***

Groupe : Membres
Messages : 569
Inscrit : 08/06/05
Lieu : Dans la lune... La lune parisienne...
Membre no 10700



Gros problème !

Après avoir mis ça, mes clés usb sont reconnues... Avec un taux de transfert de 2 Ko/s en usb 1 et 5 Ko/s en usb 2 !!!

Ce serait pas censé être environ 1000 fois plus par le plus grand des hasards ???

Config : AGNULA 1.2.1 basée sur le noyau 2.6.12-3-multimedia-k7, avec une carte usb2 à base de chipset via, et des ports usb 1 gérés par le nforce premier du nom (et oui ça existe encore). Avec ça un petit 2400 +, 512 Mo de Ram etc... même si il me semble qu'une bonne partie de ces renseignements ne servent à rien.

Symptôme exact :
Image png de 260 ko qui met une bonne minute de transfert en usb2, et deux en usb 1


--------------------
Il y a 10 types deux gens : ceux qui savent compter en binaire et ceux qui savent pas.
Go to the top of the page
 
+Quote Post
Temet_Nosce
posté 27/11/2005, 14:56
Message #15


Connaisseur
**

Groupe : Membres
Messages : 427
Inscrit : 27/04/04
Lieu : Lille
Membre no 3709



Dans ton fstab, si t'as "sync" dans la ligne de ta clé, vire.

Enfin sinon, fais nous un "cat /etc/fstab" que tu colles ici AVANT de brancher la clé ET APRES.


--------------------
Don't think IBead, know IBead
Go to the top of the page
 
+Quote Post
matser1973
posté 03/01/2008, 06:53
Message #16


Nioubiz


Groupe : Membres
Messages : 1
Inscrit : 23/09/06
Membre no 21505



Salut à tous,

il y a un petit tuto plus détaillé sur le sujet:
http://astucesslackware10.free.fr/usbk/clelinux.html
Go to the top of the page
 
+Quote Post
Pub
posté
Message #












Go to the top of the page
 
Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



RSS Version bas débit Nous sommes le : 13/11/2019 - 07:56